Wattle Software - producers of XMLwriter XML editor
 Home | Search | Site Map 
XMLwriter
 Screenshots
 Features
 About Latest Version
 Awards & Reviews
 User Comments
 Customers
Download
 Download XMLwriter
 Download Plug-ins
 Download Help Manual
 MSXML Updates
 Downloading FAQ
Buy
 Buy XMLwriter
 Pricing
 Upgrading
 Sales Support
 Sales FAQ
Support
 Sales Support
 Technical Support
 Submit a Bug Report
 Feedback & Requests
 Technical FAQ
Resources
 XML Links
 XML Training
 XMLwriter User Tools
 The XML Guide
 XML Book Samples
Wattle Software
 About Us
 Contact Details
Technical FAQ

For questions related to downloading, installing upgrades, or the trial version please check our download FAQ.

TIP: If you are not sure if a particular feature is included in XMLwriter, we recommend you browse through XMLwriter's Options available from the Tools menu.


Error Messages FAQ

DocBook FAQ

XSL Transformations FAQ

Parsers FAQ

Character Encodings FAQ

TagBar FAQ

Usability FAQ

General FAQ


Q: I get a DOMDocument error message. What does this mean?

The error message means that there is a problem with the MSXML installation on your computer. XMLwriter uses Microsoft's MSXML parser by default to process XML and XML-related documents. To solve this problem we recommend the following:

  1. Update MSXML on your computer to the latest version. For instructions on how to do this please see http://xmlwriter.net/download/msxml.shtml
  2. If the problem persists, reinstall Internet Explorer. IE contains the original MSXML.dll which cannot be downloaded separately. After reinstalling IE, update the version of MSXML to the latest release by following step 1.

Please Note: XMLwriter uses the MSXML parser by default. You can configure other parsers in XMLwriter.

If you are still experiencing problems please send our tech support team your files with a description of the problem.

Q: I have a Schema referenced in my XML file but when I validate I get the error message "No Schema\DTD declaration found".

XMLwriter v1.21 does not support XSD Schemas. Version 1.21 supports XDR Schemas, which is an earlier implementation of XML Schemas, which was current when Version 1.21 was released.

XMLwriter v2.0 and onwards does support validation against XSD Schemas, DTDs, and XDR Schemas. Please download the latest XMLwriter release then try the following suggestions. This error message can occur as a result of two problems. Firstly, you may be using an old version of the MSXML parser which does not recognize Schema declarations. In this case you need to update the version of MSXML on your system. Secondly, the namespaces in your Schema declaration may be incorrect. For more information on the Schema declaration and namespaces we recommend the MSXML XSD Schema Developer's Guide.

Please Note: XMLwriter uses the MSXML parser by default. You can configure other parsers in XMLwriter, such as Apache Xerces, which also supports XSD Schemas.

Q: When I try to run XMLwriter I get an error message saying "Your system clock appears to have been set back...".

This problem can occur if the clock on your computer system has been changed during the trial period. Please email our tech support team for instructions on how to overcome this problem.

Q: When I try to run XMLwriter I get an error message saying my evaluation period has expired but this is the first time I have used the program.

This problem can occur if XMLwriter was previously installed on the computer you are using. Please email our sales team if you need more time to evaluate XMLwriter.

Q: When I try to run XMLwriter I get an error message saying "XML Writer is not installed correctly (Unable to find or wrong version of MSXML.dll). Please run XMLwriter setup again."

This error message occurs as a result of a corrupt or missing MSXML.DLL.

To re-install MSXML.DLL you will need to re-install Internet Explorer 4.01 SP1 (or higher). The original MSXML.DLL is installed on your computer when you install IE. You cannot download it separately. After re-installing IE, we recommend you then update to the latest version of MSXML.

Q: I get an error message saying "You need a newer version of HHCTRL.OCX" error.

This error means you have an old version of HTMLHelp installed. Normally HTMLHelp is upgraded when you install Internet Explorer 5. To resolve the problem you will need to download and install the HTMLHelp upgrade Hhupd.exe.

Q: I work with very large DocBook files. Is there a faster way to work with them?

A member of the DocBook mailing list has created a flat layout of the DocBook DTD. This version of the DTD has all the parameter entities substituted with their substitution text. You should notice a significant improvement using the flat DocBook DTD in your XML file. The flattened DTD can be downloaded here.

You can also use the flattened DTD in TagBar to create/edit XML documents. To install it:

  1. Download the flattened DTD.
  2. Ensure TagBar mode is set to Flat. See the Tools menu > Options > Tools (TagBar: TagBar Mode: Flat Layout)
  3. Load the flattened DTD into TagBar by selecting load TagBar from the Tools menu.
  4. Drag and drop elements from the TagBar into your XML documents.

Q: When I perform an XSL transformation I get a blank output.

We recommend you update the version of MSXML on your system. XMLwriter uses the MSXML parser by default to perform XSL transformations.

Using an incorrect namespace in your xsl:stylesheet declaration can also produce a blank output. For example:

Incorrect:

<xsl:stylesheet xmlns:xsl="http://www.w3.org/XSL/Transform/1.0">
Correct:
<xsl:stylesheet
         xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
         version="1.0">

For more information on the xsl:stylesheet declaration and namespaces we recommend the MSXML XSLT Reference.

Please Note: XMLwriter uses the MSXML parser by default. You can configure other XSL engines in XMLwriter, such as Apache Xalan, which also supports XSL transformations.

Q: Can I configure other XML parsers and XSL engines in XMLwriter?

Yes. Please see our plug-ins and User Tools pages for further details.

Q: I'm having problems displaying European characters. What can I do?

You can use the ISO-8859-1 character set for European characters. This character set is declared in the encoding attribute in the XML declaration. For example, on the first line in your XML file insert:

<?xml version="1.0" encoding="ISO-8859-1"?>

Now characters such as והצי will display correctly.

Q: Does XMLwriter support Unicode?

XMLwriter does not currently support Unicode, however, our developers are looking into implementing Unicode support soon.

XMLwriter does support the standard Windows character sets. To select a character set in XMLwriter:

  • On the Tools menu, select Options.
  • The Options dialog box is displayed.
  • In the left pane select Format.
  • Under Editor Font: Script select the character set you wish to use.
  • Click OK.

Q: I loaded a DTD into TagBar but it doesn't show all the children.

The reason you do not see the entire tree is because the default level of recursion is set to 16. This level can be changed:

  • On the Tools menu, select Options.
  • The Options dialog box is displayed.
  • In the left pane select Tools.
  • Under TagBar mode: Tree Layout, with up to XX levels, change the number of levels.
  • Click OK.
  • Reload TagBar.

Please be aware that increasing the level of recursion may result in an "out of memory" error in loosely structured or recursive DTD/Schemas. That is, elements that contain dozens of other elements which in turn contain dozens of other elements, and so on. TagBar is not designed to load files that contain excessive levels of recursion. In these cases, the Flat Layout TagBar mode is ideal. The Flat Layout TagBar mode displays an alphabetical list of all of the elements defined in the DTD/Schema including their child elements and attributes. To select Flat Layout TagBar mode:

  • On the Tools menu, select Options.
  • The Options dialog box is displayed.
  • In the left pane select Tools.
  • Under TagBar mode, select Flat Layout.
  • Click OK.
  • Reload TagBar.

Q: Every time I go to open a file, the dialog box shows the XML file type first. Can I change this?

Yes. You can configure XMLwriter to show any file type you wish. For example, if you want to view all file types every time you open a file dialog box, you can change the file types option to do so:

  • On the Tools menu, select Options.
  • The Options dialog box is displayed.
  • In the left pane select File Types.
  • Under File Filters select All Files and click the Move Item Up arrow until All Files is at the top of the list.
  • Click OK.

Q: Can I change the default syntax that appears when I open a new file?

Yes. For example, if you want to change the default XML template: on the XML menu, select Edit Default XML Template. The template will be opened in a document window ready for editing. Once you have completed editing, select Save from the File menu. Next time you open a new XML document your changes will have taken affect. To edit the default DTD/Schema template select Edit Default DTD Template or Edit Default Schema Template from the DTD/Schema menu. To edit the default stylesheet template select Edit Default XSLT Template from the Style menu.

If you wish to edit default templates not present in XMLwriter's main menus, or to add new templates, you can manually open the templates from the Wattle Software\XMLwriter 2\Templates directory where you installed XMLwriter.

Q: Can I apply syntax coloring to other file extensions?

Yes. To apply syntax coloring to other file extensions:

  • On the Tools menu, select Options.
  • The Options dialog box is displayed.
  • In the left pane select File Types.
  • Under Syntax Coloring File Types select an appropriate file type.
  • Add a new file extension to the list of extensions displayed for that file type.
  • Click OK.

Q: Can I change the default file extension of output files?

Yes. To change the default file extension of an output file created in XMLwriter:

  • On the Tools menu, select Options.
  • The Options dialog box is displayed.
  • In the left pane select XSLT.
  • Under XSL Transformation: Default output file extension enter a file extension.
  • Click OK.

Q: Can I perform batch validation/XSL transformation in XMLwriter?

Yes. To batch validate/transform files in XMLwriter, you need to create a project containing the files you wish to batch validate/transform. For more information on projects:

  • On the Help menu in XMLwriter, select Contents.
  • The XMLwriter Help Manual is displayed.
  • In the left pane, select XMLwriter Tutorial > Project Management > Performing Batch Validation/Transformation in a Project.

Q: Can XMLwriter detect externally modified files?

Yes. To set the option to check for externally modified files:

  • On the Tools menu in XMLwriter, select Options.
  • The Options dialog box is displayed.
  • In the left pane select General.
  • Select Check for externally modified files.
  • An additional option is Automatically reload externally modified files.
  • Click OK.
  • Restart XMLwriter (this only needs to be done if the files you want to check are already open in XMLwriter, and if this is the first time you are selecting this option.)

Q: How do I open a file in XMLwriter from Explorer?

Right-click on the file in Explorer and select Open With XMLwriter.

When you install XMLwriter, no file types are associated with XMLwriter. If you want particular file types to open in XMLwriter by default you will need to configure Explorer's Folder Options (Tools menu).

Q: I'm new to XML. Where should I start?

The example project, tutorial, and Help Links on the Help menu in XMLwriter are good places to start.

The example project can be opened from the introductory dialog box when you start XMLwriter. Select "Open the example project and help" from this dialog box. The example project will be opened in Project View, and the corresponding help files displayed in the XMLwriter Help window. If you already have XMLwriter open, you can open the example project Examples.xwp from the Wattle Software\XMLwriter 2\Projects\Examples directory where you installed XMLwriter.

XMLwriter tutorials can be found in the XMLwriter Help Manual:

  • On the Help menu in XMLwriter, select Contents.
  • The XMLwriter Help Manual is displayed.
  • In the left pane, select XMLwriter Tutorial



© Wattle Software 1998-2017. All rights reserved.